Turn Signal Question

View previous topic View next topic Go down

Turn Signal Question

Post by AirKewled on Thu Feb 05, 2009 10:56 am

I replaced my turn signal not too long ago, and when I went to use it, the left works fine, but the right does not. When I try to use it on the right, the GEN light comes on, and it will not blink at all. The left side does not have that problem and works fine. I am thinking that there is something making contact with some metal inside. Does this sound possible?
avatar
AirKewled
Dub Noob

Number of posts : 13
Age : 40
Location : Fort Stewart, GA
Registration date : 2009-01-28

View user profile

Back to top Go down

Re: Turn Signal Question

Post by EngineerTEN on Thu Feb 05, 2009 12:02 pm

Check your turn signal relay switch.
avatar
EngineerTEN
Dub Nut

Number of posts : 358
Age : 42
Location : Douglasville, GA
Registration date : 2008-07-29

View user profile

Back to top Go down

Re: Turn Signal Question

Post by AirKewled on Thu Feb 05, 2009 12:05 pm

Forgot to mention that I had already replaced that! So that was not it either. It baffles me...
avatar
AirKewled
Dub Noob

Number of posts : 13
Age : 40
Location : Fort Stewart, GA
Registration date : 2009-01-28

View user profile

Back to top Go down

Re: Turn Signal Question

Post by fearthefat138 on Thu Feb 05, 2009 1:05 pm

trace the wires they are crossed if the gen light comes on
avatar
fearthefat138
Dub Nut

Number of posts : 275
Age : 29
Location : cartersville
Registration date : 2009-01-05

View user profile

Back to top Go down

Re: Turn Signal Question

Post by rpm750 on Thu Feb 05, 2009 1:15 pm

Grounds, Grounds. When the ground is open the voltage tries to find a way there and it does weird thinks. drunken
avatar
rpm750
Dub God

Number of posts : 2258
Age : 52
Location : Out in the shop.
Registration date : 2008-11-11

View user profile http://forum.georgiadubs.com/

Back to top Go down

Re: Turn Signal Question

Post by 39coupe on Thu Feb 05, 2009 1:40 pm

rpm750 wrote:Grounds, Grounds. When the ground is open the voltage tries to find a way there and it does weird thinks. drunken

Grounds - very good start - I had a similar issue and it was ground related.
avatar
39coupe
Dub Nut

Number of posts : 455
Age : 42
Location : Lawrenceville, GA
Registration date : 2008-07-20

View user profile http://www.aircooledaddicts.org

Back to top Go down

Re: Turn Signal Question

Post by skunk on Tue Aug 25, 2009 11:37 am

check the blinkin relay..ckeck the ground wires to and from blinkers and make sure you have the rite bulbs
avatar
skunk
Dub Nut

Number of posts : 218
Age : 27
Location : resaca ga.
Registration date : 2008-12-29

View user profile http://www.mcnuggitsgoochhairs.com

Back to top Go down

Re: Turn Signal Question

Post by JOHNB on Tue Aug 25, 2009 1:53 pm

Mine did the same thing.The right taillamp was not grounded good.
avatar
JOHNB
Dub Noob

Number of posts : 31
Age : 48
Location : Alto,GA
Registration date : 2008-08-26

View user profile http://WWW.ATHENSVWCLUB.COM

Back to top Go down

Re: Turn Signal Question

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum