idle issues with 30 PICT-1

View previous topic View next topic Go down

idle issues with 30 PICT-1

Post by RomanBug on Thu May 03, 2012 5:27 pm

i just rebuilt and installed a 30 PICT-1 w/o the power fuel circuit. The engine is a 1300 with the 205K dist. All the passages on the carb seemed to be clear and the inside of the bowl looked like new. I had to replace the idle cutoff with a regular 55 jet since the solenoid wouldnt work.

To get the car to idle, the idle speed screw is turned pretty far in and the choke still has to be on by one or two teeth to maintain a fairly high idle. Im leaning towards a blocked passage in the idle circuit, but all blew clean. Ive checked for vacuum leaks with carb cleaner and only had a slight increase in idle around the throttle shaft. The bushing feels tight though with no slop or play in any direction.

What should i try next?
avatar
RomanBug
Dub Noob

Number of posts : 36
Location : Rome, Ga
Registration date : 2010-02-10

View user profile

Back to top Go down

Re: idle issues with 30 PICT-1

Post by vw57drvr on Sat May 05, 2012 7:20 pm

Is your throttle plate set? HOw about the o ring on the mixture screw? I still have one of those you are welcome to try. Your points aren't closing up are they? Need to stick the dwell meter back On it.
avatar
vw57drvr
Complete Dub Addict

Number of posts : 893
Age : 43
Location : Rome, Ga
Registration date : 2010-03-01

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum